I want to burn a .img file of Wheezy OS to my 8GB SD Card from Mac OS X but can't figure out how.
Any help would be appreciated.
I want to burn a .img file of Wheezy OS to my 8GB SD Card from Mac OS X but can't figure out how.
Any help would be appreciated.
First, verify the path to your SD card. You can do this by running the following command from terminal:
diskutil list
The output shows a list of disks currently mounted on the system. Here's the relevant line from my output:
/dev/disk3
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *8.0 GB disk3
1: DOS_FAT_32 RPISDCARD 8.0 GB disk3s1
In this case I can verify /dev/disk3
is my SD card because the TYPE, NAME and SIZE values are correct.
If you have an existing partition on the disk you may need to unmount it, otherwise you'll get a "Resource busy" error message when you try to write the image.
diskutil unmount /dev/disk3s1
Now to write the image file to the disk. Note the 'r' added to rdisk3
which drastically improves write performance by telling dd
to operate in raw disk mode:
sudo dd if=RetroPieImage_ver2.3.img of=/dev/rdisk3 bs=1m
Depending on the size of your SDcard this may take a while. You can press CTRL+T
to see the current status of dd
. As an example for my Samsung 8GB SD card the write speed was 12MB/s the command took 11mins to complete.
Resource busy
then go to Disk Utility, unmount your SD card and try again. It will work.
– atulkhatri
Jul 29 '17 at 19:25
There is a faq/howto available that discusses all the various OS-es. For the Mac it is (nearly) the same as under the various other types of Unix versions. The use of dd.
In short you type:
sudo dd if=path_of_your_image.img of=/dev/rdiskn bs=1m
N.B: the of=/rdev/diskn needs to be the SD card, if you do this wrong you might end up destroying your Mac system!!!! Be careful!
Be sure to use /dev/rdiskn
instead of just /dev/diskn
. This way you are not writing to a buffered device and it will complete much faster.
For a total step by step guide through this process please consult this explanation. There are 3 chapters for the Mac in this document.
The most easy way is described on the first chapter on Mac (Copying an image to the SD card in Mac OS X (Only with graphical interface)), it involves an application that does everything for you, to be complete I copy the link to this application here
Try this: ApplePi-Baker
It's free, writes IMG files to SD-Card, can prepare a NOOBS card and can make a backup to IMG of your SD-Card.
In 2020, this accepted answer is obsolete: For most cases, people should follow the new raspberrypi.org Installation Guide.
Alternatively, the community-provided Etcher tool also provides a graphical tool to burn Pi IMG files to SD card.
Sometimes the built-in SD card reader gives errors with Etcher. If you don't have a USB SD adapter, 'dd' sometimes still works although the user must take care because the wrong command may damage their mac's OS.
If you must use 'dd', the accepted answer sudo dd if=path_of_your_image.img of=/dev/rdiskn bs=1m
works (with care taken) however if you have installed Homebrew with the 'gnubin' utilities, it provides the GNU dd utility which has different syntax. For GNU dd (including Linux hosts) use 1M
instead of 1m
(otherwise you get error: "dd: invalid number: ‘1m’
" which is what inspired me to add a new answer).
You could also try: dd Utility
Features:
I made a script to burn .img or .iso files to SD card or USB.
Yes the simple answer is to just dd it, but there are some safety precautions you may want to enforce by wrapping your dd in a script;
#!/bin/bash
#
# copy_img_to_sd.sh
#
ME=$( id | grep root | wc -l | perl -p -e 's/[^0-9]+//g');
if [ "$ME" != "1" ] ;then
echo "must be root"
exit 1;
fi
IMG=$1
if [ ! -f $IMG ] ;then
echo "can not find $IMG";
exit 2;
fi
DISK=$(ls -l /dev/disk? | wc -l |perl -p -e 's/[^0-9]//g')
if [ $DISK -lt 3 ] ; then
echo "can not find sdcard";
ls -l /dev/disk?
exit 2;
fi
DISK=$(ls -1 /dev/disk? | tail -1);
R_DISK=$(ls -1 /dev/rdisk? | tail -1);
echo "we are about to do this:"
echo $(diskutil information $DISK | grep Total)
ls -1 /dev/disk?s* | grep "$DISK" | perl -p -e 's/^(.*)$/diskutil unmount $1;/g'
echo dd bs=1m if=$IMG of=$R_DISK
echo sync
echo diskutil eject $R_DISK
echo "Press [enter] to continue or [Ctrl]+[C] to cancel";
read YNM;
ls -1 /dev/disk?s* | grep "$DISK" | perl -p -e 's/^(.*)$/diskutil unmount $1;/g' | bash 2>/dev/null
dd bs=1m if=$IMG of=$R_DISK
sync
diskutil eject $R_DISK
Accidentally writing an image to your internal drive will require a fresh OS X install to correct. Backup and keep an install.log so if it ever happens to you you can laugh it off.
Found a really good link: http://www.tweaking4all.com/hardware/raspberry-pi/install-img-to-sd-card/#macosx for installing file.img on SD card, very detailed steps!
Use df
to find the device path, in this case /dev/disk2
.
$ df -h
Filesystem Size Used Avail Capacity iused ifree %iused Mounted on
/dev/disk1 465Gi 414Gi 51Gi 90% 108573777 13263821 89% /
devfs 214Ki 214Ki 0Bi 100% 741 0 100% /dev
map -hosts 0Bi 0Bi 0Bi 100% 0 0 100% /net
map auto_home 0Bi 0Bi 0Bi 100% 0 0 100% /home
/dev/disk2s1 3.7Gi 2.3Mi 3.7Gi 1% 0 0 100% /Volumes/UNTITLED